Verification is currently underway for the maintenance items.
Posted Jun 18, 2026 - 10:10 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2026 - 09:30 CEST
Scheduled
As part of our ongoing commitment to providing a secure, reliable, and high-performing service, we will be conducting scheduled maintenance on the infrastructure hosting your Imagicle Cloud services in US and Canada regions.
During this maintenance window, we will perform infrastructure improvements and platform optimization activities within our cloud environment to further enhance the performance, scalability, and reliability of the service.
Expected Impact Some services may experience a brief interruption or temporary unavailability during the maintenance window. We will make every effort to minimize any disruption and restore full service as quickly as possible. We apologize for any inconvenience this maintenance may cause and appreciate your understanding as we continue to improve our platform.
No action is required on your side.
If you have any questions or require further information, please reply to this email or contact our support team through the support portal.
Posted Jun 12, 2026 - 17:45 CEST
This scheduled maintenance affected: Canada (UCX Cloud Suite) and US (UCX Cloud Suite).